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AutoForm-DieDesigner – V3.03 Overview 
 
AutoForm-DieDesigner is a tool intended for interactive and rapid design of draw dies. 
The procedure for designing draw dies and the resulting geometric entities have been 
designed to facilitate easy and rapid verification and optimisation of the dies and 
process parameters using incremental simulations. Therefore AutoForm-DieDesigner 
V3.03 has to fulfil certain requirements which are reflected in the new functionality: 
 
- Automatic, variable filleting 
- Determination of stamping direction (die tip) 
- Automatic filling in of holes and smoothing of part edges 
- Automatic, interactive generation of binder surface 
- Automatic, interactive generation of addendum 
- 2D-simulation for pre-optimising addendum profiles 
- Fully parametric implementation of all die geometry 
 
The main objectives in the development of AutoForm-DieDesigner were ease of use, 
flexibility and speed in generating and modifying die faces. As is the case with all 
AutoForm modules, many software features have been automated.  However, when the 
design requirements are complex, the user may have to work interactively with the 
software to override the automatic parameters when necessary. This was also taken 
into account during the development of AutoForm-DieDesigner. In particular, for 
complex part geometries, the profiles used in addendum generation have to be 
carefully determined by the user. 
 
AutoForm-DieDesigner is fully parametric and all input values, as well as profile 
parameters are saved. Changing these parameters may modify any profile. 
Furthermore, data structures within AutoForm-DieDesigner are fully parameterised. 
As a result, when the binder surface is modified, all profiles of the addendum are 
automatically adjusted to the new binder surface by simply clicking on “Update”. This 
parametric functionality is sufficiently advanced that the entire part may be replaced 
by a new one and the entire addendum is adjusted to this new data. Clearly, this is 
limited to similar parts, e.g. those representing different stages of change and during 
the development life cycle. 
 
An important aspect of parametric addendums is fully automatic optimisation of the 
addendum. This feature has been fully implemented in the current version. 
 
AutoForm-DieDesigner is most appropriate for tooling concepts and addressing 
formability issues and has not been designed, to model a series production tool. The 
finer details of a die face are still best developed in a CAD-system, since the modelling 
of such details using profiles in DieDesigner may be tedious or infeasible. To address 
this requirement, AutoForm-DieDesigner V3.0 has the necessary interface to CAD 
systems (IGES, VDA-FS) as a Beta Version implementation. 
 
Areas for further improvement in V3.03 that are being currently worked on for future 
releases include: 
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- interactive generation of additional faces on the part 
- generation of addendum for double-attached parts 
- inner binders 
- automatic flange layout 
- complex profiles 
- local modification (morphing) of tool faces.  
 
The integration of AutoForm-OneStep and Drawbead-Generator has been completed 
and these functions are available in V3.03. 
 
This manual is written in the form of a tutorial workshop for AutoForm-DieDesigner. 
Several examples are used to illustrate how to work with the program to generate tool 
geometry. It also introduces the new line editor, and illustrates the generation of 
combined lines and their global modification. 
 
The examples used in Chapter 2 are provided on your CD-ROM (tar-file: training.tar). 
Directories example data for lesson1... can be extracted from this tar-file. Each 
directory contains the necessary input data discussed in the following chapters. In most 
cases you will also find a corresponding simulation (.sim) file that may be created by 
following the procedure outlined in the relevant chapter. 
 
It is recommended that the user review all of the included lessons before proceeding to 
use AutoForm DieDesigner on actual part geometries.  This is the ideal way to get 
familiar with the functionality of the software as well as its capability and limitations. 
 
Manual Usage Note:   
 
This manual is structured as a workshop with several examples to help you fully 
understand the functionality as well as underlying concepts of AutoForm DieDesigner.   
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Working with AutoForm-DieDesigner 
 
2.1  Lesson 1 – Basic Functions 
 
Simulation > New (Opens the following window) 

 
Fig. 2.1.1 New model page  
 
These units are used for post-processing 
and for setting realistic default values. 
Error tolerance determines the global 
chordal deviation used in all algorithms. 
 
In the red box titled File name, type 
“lesson1” and click OK.  This will 
open the Geometry generator window 

shown below at the default Prepare page. 
 

Fig. 2.1.2 Prepare page 
 
Tool setup defines the geometric 
position of tools relative to each other. 
The first button (on the left) means that 
the die is above the punch and binder  
The second (right) buttonmeans that the 
die is below the punch and binder. 
The buttons named Part, Binder, 
Flange and Delete refer to specific 
faces of the part and tool, respectively.  
 
- Part denotes part geometry to be 

formed in first draw.  
- Binder refers to the binder surface,  
- Flange allows working with the flange 

area.  
- Delete contains all deleted or 

unnecessary faces. 
 
V3.03 allows editing of the part  
boundary using the “Part boundary:  
Trim” function. The points can only be 
moved on the part patches in order to 
cut details of the part boundary. In 

order to activate this function the Apply button has to be used first in order to 
automatically define the part boundary. 
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Symmetry allows symmetry line to be defined, e.g., to mirror geometry about a reference 
plane. 
Select File > Import > af > OK > Select > lesson1.af  > OK 
 
The part geometry is now shown in main graphics window. 
 
Click on Prepare/Apply:  the part boundary is automatically generated.   
On this page, click on the bottom half of the vertical line (with left mouse button) 
and move it to approximately 50 mm, or use the dialog box to set the PO width to 
50. 
Click on Binder/Select Auto/Apply:  This generates the initial binder surface. 
 
Activate Main Display and press the “c” key. The part and binder are now shown 
in different colors. 
 
Click on the Addendum Tab to open the Addendum profiles page (Fig 2.1.3) 
 

Fig. 2.1.3 Addendum page with master 
profile 
Explanations for use of  Option Menus 
for Bar Width, PO Width, Bar Height 
and CB Height as well as for the  5 Icons 
can be found in chapter 3: Input 
pages. 
 
The master profile is used as the primary 
reference profile for the global 
addendum geometry. Here, global 
settings for parameters such as Width 
and Height, radii and angles can be done 
which are used as default by all other 
profiles. 
The displayed profile does not represent 
the real geometry at every position on the 
addendum because the distance between 
part and binder varies. The displayed 
master profile is a schematic drawing 
with respect of the settings for width, 
height, radii and angles.  
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The dotted circles represent various radii parameters that can be interactively changed.  
Using the left mouse button, click and drag the circle perimeter. The dimension of the 
radius is shown on the upper left corner.  
 
Click on Apply  (The Main Display should now contain the tool.) 
 
It is necessary for the binder surface to be larger. 
 
Binder tab: Adv > Min flange width 200 > Apply 
 
The binder surface is now larger, the Addendum button, however, is red because the 
addendum has not yet been connected to the new binder surface.  
 
Press Addendum > Apply and the tool is updated with the new binder. 
 
Changing the die radius: 
 
At this point we will modify the die radius in the lower corner (geometry viewed from 
+z). On the Addendum page select Options>Show All to display all available profiles. 
In the following example, profile numbers may differ slightly from those on your 
screen; Rather than use the  exact profile number, it is more important to select the 
profiles in the lower left corner area where the die radius is to be changed. 
 
Use right mouse button to click on or use the Add prf button 
  
Profile 64 > Add 64 > Add 
Profile 68 > Add 68 > Add 
Profile 77 > Add 77 > Add 
Profile 81 > Add 81 > Add 

 
The model should now 
look similar to the 
following picture:  
 
 
Fig. 2.1.4 Profiles 
selected for changing 
the die radius 
 
Hint: Previously defined 
profiles can be copied. 
Select source profile with 
the right mouse button 
and move the profile 
with the mouse button 
pressed. Release the 

  

64   

68   

77   81   
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mouse button at the destination profile (which is blue). The settings for the source 
profile have been copied to the destination profile.   
 
On the Addendum page, activate profile 77. Click on Advanced and change the die 
radius to 10 mm. Activate profile 68 and again change the die radius to 10 mm and 
press Apply. 
 
These changes should lead to a result like in Fig. 2.1.5. 
 

 
Fig. 2.1.5 Die radius 
after profiles are 
modified 
 
 
Hint: The radii can now 
be changed with the 
mouse. Click on the 
circle line with the left 
mouse button and move 
the mouse with the 
mousebutton pressed. 
The dimension of the 
radius is shown on the 
upper left corner. 
 
 
 
 

 
Generating a Drawbar: 
 
As in the procedure to modify die radius, 4 profiles have to be selectedThe two outer 
profiles are left unchanged and the two inner ones are modified.   Profile 81 having 
been selected earlier, only three need to be identified now. The inner profiles are 
modified as follows: 
  
Use right mouse button to click on or use the Add prf button 
  
Profile 85 > Add 85   > Add 
Profile 97 > Add 97   > Add 
Profile 101 > Add 101 > Add 
 
Activate profile 97 (Use the corresponding tab on Addendum page, or, in Main 
Display, click on profile with the right mouse button). The row of 5 icons at the 
bottom of the Addendum page represent available “templates” for the profiles (e.g., 
Minimum PO, Step, etc.).  Select the right-most Icon (Bar) from these templates. Next, 
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to change the profile bar height, left-click  on the right hand segment of the horizontal 
black line and move it to a height of approximately 10 mm.  You can also use the Bar 
dialog box in the Heights column to type in a value of 10. Repeat this process for 
profile 85 and press Apply. 
 
Changing the profile of the Drawbar 
 
Activate profile 97, select the fourth Template Icon (Step). Repeat this process for 
profile 85 and press Apply. 
 
Changing the profiles 
 
Under the Widths column, click on the drop-down menu beside Bar and select the 
Free option.  Similarly, under Heights click on the drop-down menu beside CB and 
select the Free option. There are now four different dashed lines that determine the 
position of the circles. These lines or circles may also be modified using the 
corresponding dialog boxes: 
 
Widths:  
Bar : Determines the width of the drawbar  
Options in Bar drop-down menu:   
Min: the drawbar will be of minimal width 
Max: the drawbar width will be maximum (e.g., Step template) 
Free: the drawbar width is user defined 

 
PO : Determines position of punch opening line (PO line) 
Options in PO drop-down menu:       
Min: Min. PO line dependent on selected radii and angles  
Free: PO line user defined 
 
Heights:  
Bar : Determines height of draw bar 
Options in Bar drop-down menu:   
Part: Height is measured from part 
Bndr: Height is measured from binder 
Tngl: Height is measured from tangential elongation of part 
 
CB : Determines position of CB height line (Counter bar) with respect to Part 
boundary (Caution: In version 3.01 the height was measured with respect to bar 
height) 
Options in CB drop-down menu:  
Free = Counter bar user defined 
Off = no Counter bar 
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Fig. 2.1.6 Various addendum parameters 

 
You should try to create different profiles using these lines to develop a feeling for 
modifications that are permissible and that are not. In some cases the lines cannot be 
moved further because input for circle radii, wall angles and tangent face (plus) 
prohibit further movement. This constraining feature ensures that it is not possible to 
create extreme or infeasible addendum designs.  You should also try to change these 
parameters and understand their effect on the profile. 
 
CLARIFY: Tip:  If no smooth surfaces result, it is in most cases because of the fact 
that here the radii and angle specifications are not realizable with the given punch 
opening line.  It in most cases helps to modify the punch opening line e.g. to increase 
PO. 
 
Changing the punch opening line (PO line) 
 
Now, let us change the punch opening line using the PO width. This line is initially 
automatically generated along the edge of the running profiles.  
 
Click on Lines > PO width > Edit ... 
 
Right-click on the center of the upper side of the PO line thus creating a new point and 
drag this new point up. This changes the punch opening line. This method allows you 
to add, delete or move points until the line meets your requirements. Pressing OK 
accepts the changes, and the profiles are adjusted automatically to the new PO line 
which then results in an automatic update to the addendum surface (see Fig. 2.1.7) 

Part 
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Fig. 2.1.7 Modified punch-opening line (PO width) 

 
Besides these local changes to the punch opening line, global changes are also 
possible: 
 
Click on Lines > PO width > Edit... > Global mod 
 

 
Fig. 2.1.8 Global parameters for changing lines 

 
Moving the Expand slider to the right uniformly increases the size of the PO line. 
Moving the Smooth slider to the right smoothes the line.  Move the Convex slider 
completely to the right. The PO line gets a convex shape. Finally, press OK. 
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Manual editing of the bar height line: 
 

Fig. 2.1.9 Editing the 
Bar height line 
 
The Bar height line 
passes through the 
highest point of the 
drawbar. 
 
Select Options>Show 
Profiles (shows only the 
modified profiles) 
 
Select Lines > Bar 
height > Edit... 
 
Click approximately at 
the center between points 
at either end of the 
drawbar (right mouse 

button), and drag the point (only movement in the z-direction is possible). 
 
 
Move the point to generate a smooth profile for the drawbar. Then press OK. 
Addendum is now automatically adjusted to the new Bar height Line. 
 
Editing the CB height line (only if CB option is free): 

The CB height line describes the position of both left profile circles in Figure 2.1.6. 
 
Select Lines > CB height > Edit ... 
 
Rotate the model in the main display window to see a good view the CB height line. 
You can see that the profiles between part and drawbar are no longer even (flat) but 
vary in inclination due to the change of the Bar height line. Delete all nodes between 
the start and end profiles for the modified bar height region and the line becomes 
straight once again. To delete a point, select it with the right mouse button (turns 
yellow) and press the Delete key and click on OK. Once the intermediate points have 
been deleted, the addendum becomes even along the length of the drawbar. 
 
Click on Dismiss in characteristic lines menu 
 
Bar height Line and CB height line are used to smooth selected regions of the 
addendum in order to ensure uniform punch contact. 
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Changing the drawing depth: 
 
Click on the Binder tab. Adjust the value of Shift Binder to 40 mm. Go back to the 
Addendum tab and press Apply.  You can notice that the distance between the binder 
and part has increased and the addendum surface connecting part to binder also 
correspondingly increases.  
 
The default value for binder shift is 20 mm; this may be adjusted to the tool and the 
specific process. 
 
This example demonstrates the underlying parametric link between the various 
functions available in Die-Designer V3.03. 
 
Export of Addendum Surface: 
 
In V3.03, the addendum surfaces can be exported to CAD systems in IGES or VDAFS 
format. 
 
File>Export Addendum Surface 
Note: This option is implemented as a test version in V3.03 
 
Saving the simulation 
 
In main menu Simulation > Save Writes the simulation file to the hard disk. 
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2.2 Lesson 2 – A simple tool 
 
Simulation > New > File name: lesson2 > OK 
 
In Geometry generator: 
 
File > Import > af  > OK > File: lesson2.af > OK 
 
Prepare page: Symmetry > x-z plane 0 > OK then Apply 
 
Fill page:  Outer bndry fill > 500   then Apply 
 
Binder page:Auto > Uniform   then Apply 
 
Addendum page: On Master Profile, drag the vertical line to 50 mm (PO width 
50)   then Apply 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 2.2.1 Automatically generated tool  
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2.3 Lesson 3 – Significance of profile orientation 
 
Simulation > New > l esson3 > OK 
 
Geometry generator: File > Import > af > OK > lesson3.af > OK 
 
Symmetry > x-z-plane y=0 > OK 
 
Select the faces describing the license plate bay (shift + right mouse button) 
 

 
Fig 2.3.1 Faces of 
the license plate 
bay are highlighted 
when selected 
 
 
Hint: The delete 
register will not 
delete the faces 
finally, but they will 
not be used in the 
following steps 
 
 
 
 
 
 

 
Press Delete. The selected faces disappear.  Now click on Apply. 
Select Fill Page:  Hole 
Right-click on the generated hole boundary. Press Apply. 
Activate the Main Display and press “c”, to turn the colors on or off. 
 
On the Binder Page, select the following:  
  
Auto > Minimum > Max bndry slope 10 > Angle diff 10  
Click on the Adv tab and select Min flange width 250 > Apply 
On the Addendum Page: Select PO width 140 > Apply  
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Fig 2.3.2 Profile directions are orientated perpendicular to the part and do not 

follow the feature-lines 
 
It should be obvious that the orientations of the feature-line change directions because, 
by default, the created addendum profiles are perpendicular to the part edge. For this, 
as well as other parts, it is important to modify the profile orientation such that the 
addendum feature-lines are aligned properly with the part feature-lines. This is 
accomplished using the Directions  ...button. 
 
In V3.03, profiles that undergo a change in direction are automatically fixed (and 
shown in red). The intermediate profiles are oriented with respect to the fixed ones. 
 

 
 
 
Fig 2.3.3 Automatically fixed 
profiles (shown in red) 
 
 
 
 
 
 
 
 
 
 

The fixed and free profiles shown above can be selected with the right mouse button. 
For the current example, it is sufficient to rotate and re-align three profiles.  
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Fig. 2.3.4 
 
Profile orientations are adjusted 
to part feature lines orientation 
 
 
 
 
 
 
 

The directions of the three profiles in the middle are changed (from left to right in this 
example). The intermediate profiles will then be oriented such that they are either 
parallel or regular interpolated  in case of a change of directions. It is important that 
profiles do not intersect one another. It is also important that they do not converge 
towards one another when moving away from the part because this can result in 
intersecting profiles when the PO line is expanded. In most cases this will result in 
absurd faces. 
 
Press OK. The addendum should look like Fig. 2.3.5. 

 
 
Fig 2.3.5 
 
Addendum after 
modification of profile 
orientation 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
In the next step the punch opening line will be modified 



 

 16 

 
Lines > PO width > Edit 
 
Modify the punch opening line using the techniques described earlier according to Fig. 
2.3.6. 

 
 
 
Fig. 2.3.6 Addendum 
after modified punch 
opening line 
 
Now change the Master 
Profile. Use the middle 
mouse button to click in 
the profi le window.  
This adjusts the profile 
window to full view (Fit 
to Window).  
Choose the right 
template icon (Bar).  
Then click with the left 
mouse button on the 

right side of the dashed horizontal line and drag this up to approximately 20 mm.  
In the Heights column, change the Bar drop-down menu option to Bndr. 
 
Now, the height of the draw bar will be measured with respect to the binder surface).  
Set the draw bar height to 80. The profile should look as shown in Fig. 2.3.7. 

 
Fig. 2.3.7 Adjusted master profi le 
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Click on Advanced and enter the following values:  
 
Die radius   8  
Wall Angle   15 
Punch Radius 35 
CB radius   30 
 
Press the Return key and observe the effect on the profile. 
 
Dismiss 
 
The radii can now be changed with the mouse.  
 
Left-click and drag on the circle line. The radius is shown on the upper left 
corner. 
 
Drag the lower horizontal line downwards as far as possible. 
 
The profile should now look like the following: 

 
Fig. 2.3.8 New master profile 

 
Press Apply. The blended profile leads to the following addendum 
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Fig. 2.3.9 Addendum generated by one blended profile 
 
Editing the Plus parameter 
 
Plus is defined as that part of the addendum that contains the laid out flanges. The 
Plus region should not be used to model beads within the addendum. This could lead 
to strange and unusable results when AutoForm interpolates between the profiles. The 
Plus Parameters are located in the Advanced Menu and have the following meaning: 
 
Edge radius:   Radius of the part, default value 3 mm 
Edge angle:   Angle with respect to z-direction, default value 5º 
Flange radius: Tangential radius of run off at edge of part, default value 5 mm 
Flange angle(incr): Angle with respect to tangent at edge of part, default value 0º 
Min. Flange angle: Min. flange angle with respect to horizontal direction 
Max. Flange angle: Max. flange angle with respect to horizontal direction 
 
Min. Flange angle and Max. Flange angle are limits, in order not to exceed the 
max/min cutting angle. 
 

There are two additional parameters 
 
Plus width:  Width of Plus region, default 0 mm 
Plus height:  Height of Plus region, default 0 mm 
 
These values depend on one another to a certain extent in the calculation of minimum 
values. Fig. 2.3.11 explains the meaning of these parameters. 
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Fig. 2.3.11 Plus parameters 
 
Make the following changes for this part: 
 
Plus width=10 and Plus height=5 > Apply 
 
The profile directly adjoining the part is changed, and there is a new edge within the 
addendum. 
 
 
Adding and editing profiles 
 
Select profiles at the areas of the addendum where you would like to create a new 
profile that is different from the master profile. Use: 
 
Add prf  >     1 > Add 
Add prf  > 414 >  Add 
Add prf  > 401 >  Add 
Add prf  > 398 >  Add 
Add prf  > 381 >  Add 
Add prf  > 349 >  Add 
Add prf  > 309 >  Add 
Add prf  > 223 >  Add 
 
 
 
 
 

Plus 
widt

Edge 
radiu
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Edge 
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ge 
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Fig. 2.3.12 Profiles selected on the addendum 
 
 
A second possibility to do the editing is to display all profiles (Options All) and to 
select profiles with the right mouse button.  
 
A third option is to copy or move profiles: Click on a predefined profile with the right 
mouse button and drag it to another profile. You now have the possibility to choose 
between copying or moving the original profile. In case you have made a wrong 
selection use the Cancel button. 
 
Dragging the profile outside the part area deletes it. 
 
Editing profiles 
 
Select the profile to be edited. You can graphically change (mouse click+drag) values 
for Punch radius and CB radius. 
 
Profile 1: as Master 
 
Profile 414: as Master 
 
Profile 401: CB radius 52   Punch radius 52 
 
Profile 398: CB radius 55   Punch radius 60 
 
Profile 381: CB radius 39  Punch radius 44 
 
Profile 349:    Punch radius 40 
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Profile 309: as Master 
 
Profile 223: drag CB radius down as much as possible (lower horizontal line) 
 
Apply 
 
The resulting addendum is shown in Fig 2.3.12 
 

 
 
 
 
Fig. 2.3.12 
 
New addendum 
generated using 
modified profiles 
 
 
 
 
 
 
 
 
 

 
 
Smoothing the Drawbar: 
 
The feature-lines of the part run through the entire addendum. To smooth them, the 
Bar height line is used 
 
Lines > Bar height > Edit... 
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Fig. 2.3.9 New Bar height line 

 
Edit the line by deleting and moving the nodes until you get a result similar to that 
shown in Fig. 2.3.9. The nodes can only be moved in z-direction. 
 
Deleting points:  
 
Click points (yellow) and press Delete with active Main Display 
 
Adding points: 
 
Click line with right mouse button (not on existing point) 
 
Moving points:  
 
Right-click (point turns yellow) and drag points to desired location. 
 
Simulation > Save 
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2.4 Lesson 4 – From DieDesigner to simulation 
 
Simulation > New > lesson4 > OK 
 
File > Import > af > OK > lesson4.af > OK 
 
Prepare Page: Apply 
 
Fill Page:  Outer bndry fill > Smooth radius 100 > Apply 
 
Binder Page:  Auto > Uniform > Angle 90 > Apply 
 
Addendum Page: PO width 50 > Apply 
 
 

Figure 2.4.1 First model for Addendum 
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Changing the Directions (Profile re-orientation) 
 

Change profile orientations using Directions (Addendum page) as shown in Fig. 
2.4.2.  
 
 

 
 

Fig. 2.4.2 Modified profile orientation 
 
The addendum should be similar to the one shown below (Fig. 2.4.3) 
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Fig. 2.4.3 Addendum after changing the profile orientation (Directions) 
 

Changing the punch opening line 
 

 
 

Fig. 2.4.4 Addendum after modifying punch opening line (PO width) 
 
Lines > PO width > Edit > Global mode > Convex = 1 > OK 
 
Reading a PO line from file 
 
Model > Curve manager > File > Import > af > lesson4_pol.af > OK >Dismiss 
Lines > PO width select  
 Select the line with the right mouse button or click on Line 1, then OK. 
 

 
 

Fig. 2.4.5 Addendum with imported PO line. 
 
 
Model > Curve manager > line 1> clear > Dismiss 
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Smoothing the punch radius 
 
Rotate the part around as shown in Fig. 2.4.6 
Lines > Bar height Edit  
Change the Bar height line according to Fig. 2.4.6. 
 

 
 

Fig. 2.4.6 Editing the Bar height line 
OK 

 
 

Fig. 2.4.7 Addendum after smoothing the Bar height line 
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Dismiss in Characteristic Lines. 
 
Reading a binder from file 
 
Binder > Delete > Delete 
 
Import > af > OK > lesson4_binder.af > OK 
 
Addendum > Apply 
 

 
 
Fig. 2.4.8 
 
Addendum with 
imported binder 
surface 
 
 
 
 
 
 
 
 
 
 
 

 
 
Starting a simulation: 
 
Model > Input generator > OK 
 
Note:  Stamping direction/tool setup can be modified only on Prepare page) 
 
Title:   Defined by default in this version 
 
Tools:  Geometry is already defined. DieDesigner distinguishes between Part 

Geometry, Fill Geometry, Addendum, and Binder. The separation follows 
the following order: 

 
Die:   Part + Fill + Addendum + Binder 
Punch: Part + Fill + Addendum 
Binder:  Binder 

 
Select Blank > Input and press Ctrl-Z  to re-orient the view to the Z axis. 
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To define the blank outline use the Ctrl + right mouse button to sketch the line 
segments from point to point.  Click on the first point of the curve in order to close the 
line. 
 
Once a line has been closed, you cannot add additional points AFTER the last one. 
However, points can be added and moved on already defined lines. 
 
OK when the blank matches Fig. 2.4.9. 
 
 
 

 
 
 
 
 
Fig. 2.4.Blank 
 
 
 
 
 
 
 
 
 
 
 

Process > Gravity > Upwards > (Die) stationary 
 
Job > Start 
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2.5 Lesson 5 – Manual Binder 
 
The Initial steps here are similar to those in Lesson 3: 
 
Simulation > New > lesson5 > OK 
Geometry generator: File > Import > af > OK > lesson5.af > OK 
Symmetry > x-z-plane 0 > OK 
 
Select the faces describing the license plate bay (shift + right mouse button)  
 
Press the Delete key. The selected faces disappear from the main display window 
Click on Apply. 
 
Fill Page>Hole: Select the boundary of the generated hole with the right mouse 
button. Press Apply. 
 
Activate the Main Display and press c. 
 
Binder Page:  Auto > Minimum > Max bndry slope 10 > Angle diff 10 
Adv >  Min flange width 250 > Apply 
 

 
 
 
 
 

Fig. 2.5.1 

Automatically generated 
binder surface 
 
 
 
 
 
 
 
 

Upon selecting the Binder Page the drawing depth is shown as a color contour map 
with a legend at the bottom of the main display window. This post variable may be 
switched on or off in the menu Display > Drawing depth. The range may be edited in 
Display>Ranges ... For this part, set:  
 
Display > Ranges > Manual 0 80 > Return > Dismiss 
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The binder surface may now be edited manually. To do so, select Manual  on Binder 
page: 

 
 
 
Fig. 2.5.2 
 
Input menu for manual 
editing of the binder surface 
 
 
 
 
 
 
 
 
For manual editing of the 
binder surface you have to 
create lines (profiles) that can 
be modified using the curve 
editor. To create profiles, use 
the red Add button. 
 
 
 

 
 
Add:   Right-click in the middle of the topmost part boundary curve and release the 

mouse. Now, move the cursor towards the opposite (lowermost) part-boundary 
curve and press the right mouse button once again.  Repeat this with procedure 
going from the left to right on the part boundary curves. 

 

Hint: Use Shift + right mouse button to obtain horizontal or vertical lines 

 

To modify the binder surface you need at least two intersecting lines, Fig. 2.5.4. 

 

Fig. 2.5.3 User-prompt when adding 
cross profiles 
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Note:  Selecting “Use part profiles” will take the part geometry as a template for 
the binder profile. This option has to be selected before adding new profiles.  

A manually edited binder is no longer parametric. After using the profiles you can no 
longer obtain the original binder, i. e. not all lines can be deleted. If you wish to do so, 
the entire manual binder needs to be deleted. After deletion, the original binder can be 
re-created using Auto > Apply or Import. 
 

 
 
 
Fig. 2.5.4 
 
At least two intersecting lines are 
required to modify the binder 
 
 
 
 
 
 
 
 
 

 
OK > OK 
 
Upon rotating the model out of the top view in Main Display you will see blue and 
yellow lines: 
 

Blue lines: Profiles of the binder  
Yellow lines: Profiles of the part or the selected profile of the binder. 
 
The profiles of the binder can be selected by clicking the left mouse button on the 
Binder page or clicking the right mouse button in the Main Display (The profile will 
be highlighted with yellow color).  
 
Modifying the binder: 
 
Select one of the binder profile curves and press Edit curve... 
 
Clicking on an existing point activates it. It is possible to drag the activated point by 
holding the right mouse button pressed. Clicking at a point on the line creates a new 
point, which can also be dragged with the right mouse button. Press OK if the line 
meets your needs. 
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The binder is immediately updated and you can see the new "Drawing depth" (that is, 
the distance between binder surface and the part) in color. Binder profiles at 
intersections are adjusted to the edited curve. This requires a mesh of curves to fix the 
binder edges. 

 
 

Fig. 2.5.5 Binder with additional profiles along the edge 
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Fig. 2.5.5 Manual Binder Page 
 
 
 
 
 
 
 
 
 
 

 
 
 
Other options on the Manual Binder Page: 
 
Edit grid... here can you change the size of the binder. 
 
Position of reference binder shows the theoretical maximal drawing depth. Using the 
arrow buttons, you can move the binder surface with respect to the part. This feature 
can be only used to check the contact of the punch. From contact and From closed 
shows the distance from contact and from contact position respectively.   
 
Binder position shows the position of the binder for the generation of addendum 
(Shift).  
Min.shift shows the minimal value, for which the part geometry is positioned 
entirely beneath/above the binder. 
 
Drawing depth shows the drawing depth with respect to the first theoretical contact 
position.  
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2.6 Lesson 6 – Tip angle  / Definition of drawing direction 
 
The Tip page provides an easy way to modify the stamping direction of a part to a 
more suitable direction. This feature has been considerably enhanced in V3.03. 
 
Simulation > New > lesson6 > OK 
 
Geometry generator: File > Import > af > OK > lesson6.af > OK 
 
Symmetry > x-z-plane 0 > OK 
 

 
Fig. 2.6.1 Tip Page 
 
Reference geometry allows the 
import of a previous rotated 
geometry and maintains this 
rotation  
Define... defines a local axis 
system  
Average normal  defines the 
normal (perpendicular) vector as 
stamping direction 
Min draw depth chooses the 
drawing direction with a 
minimum drawing depth.   
Min backdraft minimizes the 
undercuts 
Use screen axes defines the 
direction of the perpendicular to 
the current orientation of part on 
the screen as stamping direction.  
Reset discards all changes and 
uses the original CAD z-axis for 
stamping direction.  
Import... allows the user to read 
in a rotation matrix from file  
Export... enables you to write a 
rotation matrix to file in VDAFS-, 

IGES-, or AF-Format  
Plot shows all possible stamping directions in one 2D diagram. The vertical axis 
represents the possible rotation around the y-axis and the horizontal axis represents the 
rotation around x-axis.  
 
All potential backdrafts may now be calculated for each drawing direction and 
displayed in color.  
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Display > Backdrafts in the geometry generator.  (Default values for the Tip 
page). 
 
Fig. 2.6.2 shows the result for the imported geometry.  
 

 
 
 
Fig. 2.6.2  
 
Representation of 
backdrafts 
 
Safe: > 3º 
 
Marginal : 0º<3º 
 
Severe: < 0º 
 
The delimiting 
angles 
severe/marginal 
(default 0º) and 
marginal/safe 
(default 3º) can 
be user defined.  

 
In order to 

determine a suitable stamping direction it is recommended to start with the option 
Average normal  and then look at other alternatives using the options Min draw 
depth and Min backdrafts. Then activate the 2D-diagram with Plot.  In case none of 
the options lead to an appropriate stamping direction you can manually rotate the part 
until all backdrafts (red and/or yellow regions) disappear.  
 
Average normal  Rotation and update of backdraft faces are carried out 

immediately.  
Min draw depth stamping direction having minimal drawing depth 
Min backdrafts stamping direction having a minimized backdraft  
Plot 2D-diagram to illustrate the possible stamping directions free of 

backdrafts  
Y-Axis > by 1 degrees > -  stamping direction of the hood without backdrafts  
X/Y/Z-Axis Definition of the rotation angle around each axis. It is necessary to 

follow the exact order of the rotation (i.e., rotation around x-axis, 
then y-axis then z-axis)  
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2.7 Lesson 7 – Automatic and variable filleting 
 
The present version allows filleting of all sharp edges using a global radius. In 
addition, the user can select edges to be filleted with a constant or variable radius.  
 
Simulation > New > lesson7 > OK 
File > Import > afb > OK > lesson7.afb > O  
Fillet Tab : Check:     Checks geometry for sharp edges 
OK:  Acknowledges sharp edges  
 

 
 
 
 
Fig 2.7.1 Sharp edges 
 
 
 
 
 
 
 
 
 
 
 
 

Global Radius=3 Specifies a global fillet radius of 3 mm.  
  Apply   Runs filleting to fillet all edges with a 3 mm radius. 
 
In case it is desired to fillet individual edges with radii different from the global 
setting, it is necessary to specify both the edges and radii values to be used. Use the 
Add line... button at the bottom of the page to achieve this. 
  
Add line ... Opens a window with the pop-up box   “Mark radius control edge 
        Finish with double click” 
 
You may now click on the desired edge using the right mouse button. Release the 
button and move the mouse along the edge. The edge is highlighted in yellow. Double 
click with the right mouse button to finish. You may now enter values for different 
radii. 
 
Constant Constant radius along the edge 
 
Variable Click points along the edge for which a specific radius is desired (right 

mouse button), then press OK. Radii are entered in a table. 
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Note:  When working with long curved edges, the direction of the curved edge 
may not always be detected correctly. If this happens, it usually helps to 
click on the edge with the right mouse button. 

 
Fig 2.7.2 Fillet page 
 
Example definition for an edge to be filleted 
with a constant radius. 
 
Filleted geometry shows the filleted part. 
 
Edged geometry shows the original, 
unfilleted part with the sharp edges found. 
 
The above display buttons are not active 
until after Apply is pushed for the first 
time. 
 
 
 
 
 
 
 
 

 
 

 
 
Fig 2.7.3 Definition of an edge with 
variable radii 
 
Variable radii are defined by means of a 
table. The entries in the table represent 
points along the edge, which have to be 
defined first. Points can be added to the 
edge after pushing the Add point ... 
button to the right of the table. Clicking 
the edge with the right mouse button sets 
the points. Once all desired points have 
been set, push the OK button and enter 
the radius for every point into the table. 
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Two edges of the following part receive radii other than the global filleting radius. 

 
 
Fig 2.7.4 Edges with constant and variable radii 
 
The left edge receives a constant radius of 8 mm and the right 
edge (yellow) a variable radius starting at 5 mm that rises to 8 mm 
and then drops again down to 5 mm. 
 
 
 



 

 39 

Chapter 3 AutoForm-DieDesigner – Input Pages 
 
3.1 Prepare Page 

 
 
Fig. 3.1  Prepare page 
 
The Prepare page is used to work with 
the imported CAD geometry.  
 
Tool setup defines the geometric 
position of tools. The left button means 
die is above, punch and binder are 
below and the right button means die is 
below and punch and binder are above. 
 
Buttons Part, Binder, Flange and 
Delete refer to specific faces of part and 
tool, respectively. Part denotes part 
geometry to be formed in first draw. 
Binder refers to the binder surface, and 
Flange allows working with the flange 
area. Delete contains all deleted or 
unnecessary faces. 
 
The definition is done by selecting the 
patches (clicking with right mouse 
button) and pressing the register button 
(left mouse button). 

 
Error tolerance determines the chordal error for generation of part boundary and 
Concatenation distance is the distance in which points can be merged. 
 
The Part Boundary can be edited now.  The points can only be moved on the part 
patches in order to cut details of the part boundary. The name of the function is 
therefor Trim. To activate this function the button Apply has to be used first in order 
to get the part boundary. 
 
Symmetry allows defining a symmetry line. 



 

 40 

3.2 Fillet Page 

 
 

Fig. 3.2.1 Fillet Page 
 
Check checks geometry for radii 
smaller than Check radius. OK accepts 
the result. 
 
Filleted geometry shows the part with 
fillets. Edged geometry shows part 
without fillets but with detected sharp 
edges. 
These buttons are active after Apply. 
 
Constant or Variable is the option for 
specifying radii for selected lines. The 
line has to be defined by Add line ... 
before. (After pressing Add line... the 
starting point of the line can be selected 
with right mouse button in Main 
Display, release mouse button and 
follow the line which should be selected 
with the mouse. Finish with double 
click of right mouse button. 
 
The specification of variable radii is 

done in a table. At first all points for which a radius should be specified have to be 
defined on the line. This is done with the Add point ... button next to the table. The 
definition of the points is done by clicking on the line with the right mouse button. 
When all points are defined, press OK and specify the radii in the table. 
 
Delete deletes active line. 
 
Delete all deletes all lines. 
 
Tip: At a “T-junction”, it is possible that the directions of the line are not recognised. 
Normally it helps to click once on the line with the right mouse button. Of course the 
clicking must be done when the selection of the line is still the right direction. 
 
 
 
 
 
 



 

 41 

3.3 Tip Page 
 

 
Fig. 3.3.1 Tip Page 
 
Reference geometry allows the import 
of a previous rotated geometry and 
maintains this rotation  
 
Define... defines a local axis system  
 
Average normal  defines the normal 
(perpendicular) vector as stamping 
direction 
 
Min draw depth chooses the drawing 
direction with a minimum drawing 
depth.   
 
Min backdraft minimizes the 
undercuts 
 
Use screen axes defines the direction of 
the perpendicular to the current 
orientation of part on the screen as 
stamping direction.  
 

Reset discards all changes and uses the original CAD z-axis for stamping   
 
Import... allows to read in a rotation matrix from file  
 
Export... enables you to write a rotation matrix to file in VDAFS-, IGES-, or AF-
Format  
 
Plot shows all possible stamping directions in one 2D diagram. The vertical axis 
represents the possible rotation around the y-axis and the horizontal axis represents the 
rotation around x-axis.  
 
Safe and Marginal  allow the specification of angles for the transition Severe/Marginal 
and Marginal/Safe. 
 
X-/Y-/Z-Axis  specifies the rotation around the specific axis. The sequence rotation 
around x then y then z must be kept. 
 
 
 
 



 

 42 

3.4 Fill Page 
 
Fig. 3.4.1 Fill Page 
 
Roll Radius is the radius of the 
cylinder, which rolls around the part 
boundary. 
 
Edit edits the new boundary. To 
activate this button Apply has to be 
pressed. 
 
Outer bndry fill generates a new 
smoothed outer boundary. 
 
Inner bndry fill generates a new 
smoothed inner boundary.  
 
All holes fills all holes in part 
geometry. 
 
Hole ... fills one selected hole in part 
boundary. 
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3.5 Binder Page 

 
Fig. 3.5.1 Automatic Binder – 
Standard  
 
These options are specifications for the 
optimization algorithm, which 
calculates the binder surface. 
Sometimes the algorithm can not fulfil 
all the specifications made by the user. 
 
Drawing depth specifies the desired 
drawing depth (i.e., min, max or 
uniform). 
 
Profile Orientation specifies the 
direction of the main curvature of the 
binder surface. 
 
Max bndry slope specifies the slope at 
the boundary of the binder surface. 
 
Angle diff specifies the max. difference 
between the slope angles of right and 
left boundary of the binder surface.  

 
 
Flexibility specifies the number of splines used for the binder profiles (min: 3 and 
max: 20) 
 
Control points allows the user to specify additional control points, in order to change 
the shape of the binder surface. 
 
Binder position shows the displacement (Shift) of the binder surface for the 
generation of the addendum.  
 
Min.shift shows the minimum shift for which the binder surface is totally below/above part 
geometry. 
 
Drawing depth shows the drawing depth with respect to the initial punch contact. 
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Fig. 3.5.2 Automatic Binder – 
Advanced Tab 
 
Profile expansion specifies the slope 
(Transverse inclining), warping 
(Warping) and curvature (Transverse 
curving) for the second direction of the 
binder surface. 
 
 
Min flange width specifies the size of 
the binder surface. The value is the size 
of the binder outside of part boundary. 
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Fig. 3.5.5 Manual Binder Page 
 
 
Edit grid... here can you change the size 
of the binder. 
 
Position of reference binder shows the 
theoretical maximal drawing depth. 
Using the arrow buttons, you can move 
the binder surface with respect to the 
part. This feature can be only used to 
check the contact of the punch. From 
contact and From closed shows the 
distance from contact and from contact  
position respectively.   
 
Binder position shows the position of 
the binder for the generation of 
addendum (Shift).  
 
 

Min.shift shows the minimal value, for which the part geometry is positioned entirely 
beneath/above the binder. 
 
Drawing depth shows the drawing depth with respect to the first theoretical contact 
position.  
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3.6 Addendum Page 
 

 
 
Fig. 3.6.1 Addendum page with 
master profile 
 
The master profile is used as reference 
profile. Here, global settings for 
parameters Width and Height, radii 
and angles can be done which are used 
as default by all other profiles. 
The displayed profile is not the real 
geometry at every position of the 
addendum because the distance 
between part and binder varies. The 
displayed master profile is a schematic 
drawing with respect of the settings for 
width, height, radii and angles.  
 
The radii can now be changed with the 
mouse. Click on the circle line with the 
left mouse button and move the mouse 
with the mousebutton pressed. The 
dimension of the radius is shown on 
the upper left corner. 

 
Widths:  
Bar:  Determines the width of the drawbar  
Options in Bar drop-down menu:   
Min: the drawbar will be of minimal width 
Max: the drawbar width will be maximum (e.g., Step template) 
Free: the drawbar width is user defined 

 
PO:  Determines position of punch opening line (PO line) 
Options in PO drop-down menu:       
Min: Min. PO line dependent on selected radii and angles  
Free: PO line user defined 
 
Heights:  
Bar:  Determines height of draw bar 
Options in Bar drop-down menu:   
Part: Height is measured from part 
Bndr: Height is measured from binder 
Tngl: Height is measured from tangentiall elongation of part 
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CB : Determines position of CB height line (Counter bar) with respect to Part 
boundary (Caution: In version 3.01 the height was measured with respect to bar 
height) 
Options in CB drop-down menu:  
Free = Counter bar user defined 
Off = no Counter bar 
 
Plus is defined as that part of the addendum that contains the laid out flanges. The 
Plus region should not be used to model beads within the addendum. This could lead 
to strange and unusable results when AutoForm interpolates between the profiles. The 
Plus Parameters are located in the Advanced Menu and have the following meaning: 
 
Edge radius:   Radius of the part, default value 3 mm 
Edge angle:   Angle with respect to z-direction, default value 5º 
Flange radius: Tangential radius of run off at edge of part, default value 5 mm 
Flange angle(incr): Angle with respect to tangent at edge of part, default value 0º 
Min. Flange angle: Min. flange angle with respect to horizontal direction 
Max. Flange angle: Max. flange angle with respect to horizontal direction 
 
Min. Flange angle and Max. Flange angle are limits, in order not to exceed the 
max/min cutting angle. 

There are two additional parameters 
 
Plus width:  Width of Plus region, default 0 mm 
Plus height:  Height of Plus region, default 0 mm 
 
These values depend on one another to a certain extent in the calculation of minimum 
values. Fig. 3.6.2 explains the meaning of these parameters. 
 
 
 
 

Fig. 3.6.2  Plus 
parameters 
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3.6.1 Profile Templates - Nr. 1: Min PO 
 
 
 
 
 
 
 

 
This template minimizes the distance between part boundary and punch opening line. 
Bar width, Bar height and CB height are not active. The punch opening line is 
determined by: 
 
 

1. punch radius 
2. die radius  
3. Plus width (if not equal zero) 

 
 

 
 
Fig. 3.6.3: Profil Templates – Min PO 

Min PO  
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3.6.2 Profile Templates – Nr. 2: Tngtl, Free PO 
 

 
 

 
 
 
 

 
This template puts punch opening line to free, which means the user can define punch 
opening line without restrictions. The height of Bar will be measured from the 
tangential elongation of the part. Bar width is set to Min and is therefore not active. 
CB height is switch off (Off) and is therefore also not active. 
 
 

 
 
Fig. 3.6.4: Profile Templates – Tngtl, Free PO 
 
 
 
 
 
 

Tngtl, Free 
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3.6.3: Profile Templates – No. 3: Smooth (Default) 
 
 

 
 
  

 
 
 
 

 
This template puts punch opening line to free, which means the user can define punch 
opening line without restrictions. The height of Bar will be measured from the part 
(Part). In many cases it makes sense to use option Bndr. In this case Bar height is 
measured from binder surface which makes it possible to achieve a uniform initial 
punch contact. Bar width is set to Min and is therefore not active. CB height is switch 
off (Off) and is therefore also not active. 
 
 

 
 
Fig. 3.6.5: Profile Templates – Smooth (Default) 
 
 
 

Smooth (Default) 
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3.6.4 Profile Templates – No. 4: Step 
 

 
 

 
 
 

 
This template puts Bar width to maximum (Max). This results in a step in addendum. 
 Punch opening line is set to free, which means the user can define punch opening line 
without restrictions. The height of Bar will be measured from the part (Part). In many 
cases it makes sense to use option Bndr. In this case Bar height is measured from 
binder surface which makes it possible to achieve a uniform initial punch contact. CB 
height is switch off (Off) and is therefore not active. 
 
 

 
 
Fig. 3.6.6: Profile Templates – Step 

Step 
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3.6.5 Profile Templates – No. 5: Bar 
 

 
 
 

 
 

 
 
This template activates the counter bar (CB height is set to free). 
 Punch opening line is set to free, which means the user can define punch opening line 
without restrictions. The height of Bar will be measured from the part (Part). In many 
cases it makes sense to use option Bndr. In this case Bar height is measured from 
binder surface which makes it possible to achieve a uniform initial punch contact. Bar 
width is set to Min and is therefore not active. 
 
Caution: CB height is measured from part and not like in previous version with 
respect to Bar height. This means that for CB height = 0 the counter bar (CB) 
disappears. This change can lead to the effect, that the Addendum created in an older 
DieDesigner version looks different in version 3.03.  
 

 
 
 
Fig 3.6.7: Profile Templates – Bar 
 
 

     Bar 
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Menu Options 

 
3.7.1 File Menu 
 

 
Fig 3.7.1 File Menu 
 
Import reads in geometries in IGES-, VDAFS-, af-, afb-, 
Nastran- or STL-format. The imported geometries are 
numbered sequentially as they are read in for easy 
reference. The active geometry is marked by the 
depressed button beside it (e.g., lesson1) 
 
Delete deletes the current geometry.  
 

  
Export addendum profiles ... exports profiles of addendum in IGES-, VDAFS- or af-
format.  
 
Export addendum surfaces ... exports addendum surfaces in IGES- or VDAFS-
format.  
 
Export binder profiles ... exports profiles of binder (for manual binder only) in IGES, 
VDAFS- oder af-format.  
 
Export binder surfaces ... exports binder surface in IGES- oder VDAFS-format.  
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3.7.2 Display Menu 
 

 
Fig 3.7.2 Display Menu 
 
The upper half of the menu is for switching on or off, the display of 
the appropriate register  (Part, Binder, Flange, Delete) and of the 
surfaces generated by AutoForm (Binder surface, Fill, Addendum). 
 
Show al l switches display of all surfaces to on. 
 
Clear all switches display of all surfaces to off. 
 
The next four options determine the display properties of the objects: 
Color patches colors the imported patches of CAD geometry. Color 
objects colors the different AutoForm objects (Part, Binder, 
Addendum, Fill...). Backdrafts shows the undercuts of the part with 
respect to the actual tip. Drawing depth shows the drawing depth as 
a color distribution on the part with respect to binder surface.  

 
Caution: The default setting varies depending on which page you work. The settings 
can be adjusted at any time from this menu. 
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3.7.3 Options Menu 
 

 
Fig. 3.7.3 Options Menu 
 
Show log... shows the log-file. 
 
Show none shows none of the addendum profiles. 
 
Show profiles shows the defined profiles of addendum. 

 
Show all shows all profiles of addendum. 
 
Set reference... reads in a reference profile.  
 
Tolerances ... opens tolerance menu for setting tolerances (Fig. 3.7.4). 
 
 
 
3.7.4 Tolerances 
 

 
 
Fig. 3.7.4 Tolerances 
 
Error tolerance: chordal error for meshing the 
addendum. 
 
Max prf dist: defines maximum distance between 
profiles 
 
Min prf dist: defines minimum distance between 
profiles 
 

Max prf angle: defines maximum angle between profiles 
 
 
 
 
 
 
 
 
 
 
 
 


